Função SOMASES: Como fazer?

Escrito por: Guilherme Barauna

A função SOMASES do Excel é usada para calcular a soma dos valores que atendem a um conjunto de critérios. Por exemplo, você pode calcular o valor total investido em compra de jogadores para o Flamengo em 2019 usando a fórmula SOMASES.

Neste artigo, você aprenderá:

  • O que é a função SOMASES e como usá-la?
  • Sintaxe para SOMASES
  • Usando SOMASES com tabelas e referências estruturais
  • Exemplos SOMASES – simples, curinga
  • Usando SOMASES com valores de data e hora
  • Arquivo de amostra grátis para a fórmula SOMASES
  • Mais fórmulas para análise de dados

Como escrever a função SOMASES do Excel?

Usando a função SOMASES, você pode encontrar a soma dos valores em que seus dados atendem a determinadas condições.

Então, para descobrir a soma de todas as compras efetuadas pelo Corinthians em 2005, basta escrever,

=SOMASES(F3:F22;D3:D22;”Corinthians”;E3:E22;2005)

Da mesma forma, para encontrar o total gasto pelo Flamengo em aquisição de atletas na temporada de 2019, basta escrever:

as 20 maiores compras do futebol brasileiro
=SOMASES(F4:F23;D4:D23;”Flamengo”;E4:E23;2019)

Função SOMASES – Sintaxe

A fórmula SOMASES assume um intervalo para somar os valores e pelo menos um intervalo e critérios de critérios. Você pode especificar até 127 condições para somar seus dados.

sintaxe da função somases

Imagine perguntar: “quantos milhões o São Paulo gastou em aquisição de atletas Depois de 2012?” E descobrir imediatamente a resposta.
O legal da fórmula SOMASES é que ela também funciona com caracteres curinga, assim como suas irmãs – SOMASE e CONT.SE. Então você pode escrever fórmulas como,

=SOMASES(F4:F23;D4:D23;”São Paulo”;E4:E23;”>2012″) para obter o total gasto na compra de atletas pelo tricolor paulista.

Usando SOMASES () com tabelas

Você pode utilizar a função SOMASES em um intervalo de dados ou em uma tabela. Ao usar tabelas, você pode simplesmente aplicar referências estruturais – ou seja, a notação Nome da Tabela[Nome da coluna] para especificar as colunas dos critérios. Veja este exemplo:

Exemplos de SOMASES

Digamos que você tenha uma tabela chamada maiores_vendas, como mostrado acima. Veja estes exemplos para entender como a função funciona.
Vendas para Palmeiras em 2019
= SOMASES(maiores_vendas[custo(milhões de R$)];maiores_vendas[Para]; “Palmeiras”; ,maiores_vendas [ano];2019)
Vendas totais acima de 25 para Corinthians
= SOMASES(maiores_vendas[custo (milhões de R$)];maiores_vendas[custo (milhões de R$)];”>25″; maiores_vendas[Para]; “Corinthians”)
Todas as Vendas Para Corinthians exceto em 2005
= SOMASES(maiores_vendas[custo (milhões de R$)];maiores_vendas[Para]; “Corinthians”;maiores_vendas[Ano];”<>2005″)